Welcome, Guest. Please login or register.
Did you miss your activation email?

April 28, 2017, 04:46:39 PM
Show unread posts since last visit.

Home | Help | Search | Login | Register

Pages: [1]
Print
Author Topic: Build 41  (Read 4683 times)
jitspoe
Administrator
Autococker

Posts: 18540

« on: August 11, 2015, 12:41:51 AM »

Sorry it's been so long.  Things aren't as complete as I'd like, but I just wanted to get a new build out.

As always, if some kind of exploit is found in this build/pretest, it won't be allowed in the future.

Give the pretest a try to make sure there aren't any major issues:
http://digitalpaint.org/files/temp/paintball2_build041_full_pretest1b.exe

Linux: http://digitalpaint.org/files/temp/paintball2_build041_linux_full_pretest1.tar.gz

Note: this is a full install only as it contains the hr4 textures and other new data that would make a patch almost pointless.


Changelog:



build 41:
- Feature: New bots (WIP).
- Command: "demo_playernumber" allows you to specify which player to chase when viewing demos (very rough right now). 12:39 AM 2/5/2015, 1:40 AM 4/4/2015
- Bugfix: Fixed a crash loading maps with over 32k surfaces. 2:56 AM 11/1/2013
- Bugfix: Fixed jpeg loading code so it supports EXIF as well as JFIF formats. 2:05 AM 12/12/2013
- Bugfix: Fixed scoreboard not displaying on first key press after being closed with the console or ESC. 12:15 AM 1/7/2014
- Bugfix: Fixed issue with dalogs showing up as an error about not being able to find menus/dialog.txt. 12:21 AM 8/9/2014
- Bugfix: Made rcon command behave more like expected with multiple parameters and fixed potential exploits. 2:23 AM 1/10/2015
- Bugfix: Fixed possible security hole. 10:42 PM 3/27/2015
- Bugfix: Fixed for failed downloads due to backslashes. (Thanks, xrichardx).
- Bugfix: Fixed possible crash in custom menu files. (Thanks, xrichardx).
- Tweak: Tweaked min and max rate values to be higher. 12:48 AM 1/21/2014
- Tweak: Added 2560x1440 resolution support. 10:47 PM 5/18/2014
- Tweak: Added 50% black background to dialogs to make them easier to read/more obvious that you couldn't click buttons behind them. 12:24 AM 8/9/2014
- Tweak: Defaulted m_rawinput to 1, so mice will use raw input by default (on Windows). 2:24 AM 1/10/2015
- Tweak: Projects converted to and now compiled with Visual Studio 2010. 1:39 PM 1/19/2015
- Cvar: "gl_colorpolycount" - color codes the different polycounts of each brush face (red, green, blue, yellow, purple, grey, for 3, 4, 5, 6, 7, 8+ sides).  Only works offline ("deathmatch" must be 0).
- Cvar: "vid_borderless" - Allows for borderless windowed mode when set to 1. 10:54 PM 2/26/2014
- Cvar: "vid_resx" and "vid_resy" can set custom resolutions if "gl_mode" is set to "-1" (Thanks, xrichardx)
- Cvar: "timestamp_date" - if set to 1, logs will include the full date on each line. (Thanks, xrichardx)
- Media: Higher resolution textures are now included by default.
« Last Edit: August 21, 2015, 12:25:46 AM by jitspoe » Logged
Malware
VM-68

Posts: 109

« Reply #1 on: August 11, 2015, 04:06:23 AM »

Some minor bug here. I don't think it happened before but notice that kaidos has 0 kills but somehow he is in front of noname who has 4 kills, or in red team pinkunicorn in front of xdream. Are they aligned based on caps?




Also, I think it would be nice if you add disconnect button/option in this menu, like in Bono menu. When I want to disconnect from server, it would be a lot easier and faster rather than typing the command in console.




Logged
lukip
VM-68

Posts: 202

« Reply #2 on: August 11, 2015, 04:14:38 AM »

- Command: "demo_playernumber" allows you to specify which player to chase when viewing demos (very rough right now). 12:39 AM 2/5/2015, 1:40 AM 4/4/2015

this is a great feature, sadly its still "slightly" bugged, when viewing a demo from the perspective of a different player, it sometimes laggs.

EDIT: https://www.youtube.com/watch?v=qqs85ooebhk&feature=youtu.be

EDIT 2: the demo on the video is from b40, ive tried it with a b41 demo now and nothing changed
« Last Edit: August 11, 2015, 04:59:21 AM by lukip » Logged
ic3y
Committee Member
Autococker

Posts: 1378

« Reply #3 on: August 11, 2015, 06:07:49 AM »

Some minor bug here. I don't think it happened before but notice that kaidos has 0 kills but somehow he is in front of noname who has 4 kills, or in red team pinkunicorn in front of xdream. Are they aligned based on caps?


More Caps than noname
Logged
ic3y
Committee Member
Autococker

Posts: 1378

« Reply #4 on: August 11, 2015, 06:37:58 AM »

New Post because its another bug. Still working with b40

Logged
Malware
VM-68

Posts: 109

« Reply #5 on: August 11, 2015, 07:49:05 AM »

More Caps than noname

Oh, so it's not a bug. Caps and grabs now count.

Here I am, with 0 kills, first on the scoreboard.



But when the map ends, I go to last place...



Logged
ic3y
Committee Member
Autococker

Posts: 1378

« Reply #6 on: August 11, 2015, 08:23:15 AM »

But when the map ends, I go to last place...
End Screen is always buggy. Missing players in Team Blue as example.
Logged
T3RR0R15T
Map Committee
Autococker

Posts: 2582

« Reply #7 on: August 11, 2015, 10:14:05 AM »

The end screen is server-side and all other score screens are client-side, if i remember right. Thats not a new bug. Somewhere here in the forum is a feature request to make everything client-side.
Logged
xrichardx
68 Carbine

Posts: 287

« Reply #8 on: August 11, 2015, 11:33:19 AM »

A minor menu thing: In the screenshots above, you can see that in the scores menu, the width of the column headers does not match the width of the select widget below which looks strange IMO.
I would also make the scoreboard look more like the main_ingame menu by using a "bpic border1" background, like this:

Logged
DooCi
68 Carbine

Posts: 403

« Reply #9 on: August 11, 2015, 02:46:17 PM »

this shows on my cpu: THE PROGRAM CANT START BECAUSE MSVCR100.dll is missing from your computer. Try reinstalling the program to fix this problem.
Logged
xrichardx
68 Carbine

Posts: 287

« Reply #10 on: August 11, 2015, 02:57:18 PM »

Try installting the Visual C++ 2010 Redistributable Package from Microsoft.

Edit: The Microsoft Visual C++ 2010 SP1 Redistributable Package is probably better.
Logged
jitspoe
Administrator
Autococker

Posts: 18540

« Reply #11 on: August 11, 2015, 10:12:12 PM »

this shows on my cpu: THE PROGRAM CANT START BECAUSE MSVCR100.dll is missing from your computer. Try reinstalling the program to fix this problem.


Ugh... thought I had everything set up to build that stuff into executables so it wouldn't need the separate dll's.  Thanks for the heads up.

New Post because its another bug. Still working with b40



Not a bug, just not implemented yet.  The bots were rewritten from scratch, so they don't have all the old features yet.

this is a great feature, sadly its still "slightly" bugged, when viewing a demo from the perspective of a different player, it sometimes laggs.
Can't really do much about that.  The demo only contains info on entities the server sent to you.  Network traffic is optimized by not sending entities that can't be seen.  If players are on the other side of the map, you probably won't get entity updates from them.  This isn't too bad if you're reviewing demos for suspected cheating, though, as if you aren't getting updates for them, they aren't getting updates for you, either, and wouldn't know your position.
Logged
jitspoe
Administrator
Autococker

Posts: 18540

« Reply #12 on: August 11, 2015, 10:20:47 PM »

DooCi: Try removing dp_botlib.dll and see if you can launch the game without that error (should still run, just won't be able to have bots).  Looks like I forgot to remove the dll requirement on that one.  I'll build a new dll.

Edit: Put a new installer up which hopefully won't require the msvc dlls.  Try pretest1b linked in the first post and see if it fixes your issue.
« Last Edit: August 11, 2015, 11:11:35 PM by jitspoe » Logged
xrichardx
68 Carbine

Posts: 287

« Reply #13 on: August 12, 2015, 10:51:35 AM »

1b works on a fresh Windows 7 installation where 1a gives the msvcr100.dll error.
Logged
jitspoe
Administrator
Autococker

Posts: 18540

« Reply #14 on: August 15, 2015, 11:28:46 PM »

1b works on a fresh Windows 7 installation where 1a gives the msvcr100.dll error.
Awesome.  Thanks for verifying.  It sounds like the windows version is good enough. Now I just need to get the Linux version put together.
Logged
jitspoe
Administrator
Autococker

Posts: 18540

« Reply #15 on: August 21, 2015, 12:27:41 AM »

Added the Linux build to the first post.  Could somebody test that and see if there are any issues?

Also uploaded b41 to sf (reuploaded -- thanks for pointing out the incomplete file, T3RR0R15T) here: http://sourceforge.net/projects/paintball2/files/Paintball%202/Paintball%202.0%20Alpha%20build041/paintball2_build041_full.exe/download -- could somebody download and compare to the pretest1b and be sure the files match?
Logged
T3RR0R15T
Map Committee
Autococker

Posts: 2582

« Reply #16 on: August 21, 2015, 07:12:15 AM »

B41 at sf and pretest1b are the same files.

I've updated our servers and added three bots on each one to test them (public only).
Logged
Pages: [1]
Print
Show unread posts since last visit.
Jump to:  


Powered by SMF 1.1.20 | SMF © 2013, Simple Machines